FINAL FANTASY PORTAL APP
Latest News
Status
2016/03/20 07:30 from FINAL FANTASY PORTAL APP

Recovery from “Triple Triad” Technical Difficulties (Mar. 20)

Thank you for using the Final Fantasy Portal App.
At the time below, there was an issue wherein “Triple Triad” was not accessible.
We are pleased to announce that the issue has been addressed. We apologize for any inconvenience this may have caused.

[Date & Time]
From Mar. 20, 2016 4:42 a.m. to 5:52 a.m. (PDT)

[Details]
Unable to access “Triple Triad”

[Cause]
Server Equipment Issue

[Affected Service]
“Triple Triad”

We use cookies on our websites. You are free to manage this via your browser setting at any time. To learn more about how we use the cookies, please see our cookies policy.

You probably won’t be surprised to hear that we’ve updated our Privacy Notice. Please do take the time to read our new, more informative, easier to read and easier to understand, Privacy Notice.